aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorSimon Garrelou <simon@sixfoisneuf.fr>2024-02-02 14:55:36 +0100
committerSimon Garrelou <simon@sixfoisneuf.fr>2024-02-02 14:55:36 +0100
commit7a3aabee59e1a427aff755fc69759265ad9d0adc (patch)
tree083513ba6d789453a44cffdc5c15ee1f8afeb975 /shell.nix
parentf13b77b8237dbc5dbe8aaf9c4dc342b2f15c375d (diff)
downloadtermsonic-7a3aabee59e1a427aff755fc69759265ad9d0adc.tar.gz
termsonic-7a3aabee59e1a427aff755fc69759265ad9d0adc.zip
Add shell.nix
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..7f5aaaa
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,12 @@
1let
2 pkgs = import <nixpkgs> {};
3in
4pkgs.mkShell {
5 packages = [
6 pkgs.go
7 pkgs.gotools
8 pkgs.gopls
9 pkgs.pkg-config
10 pkgs.alsa-lib
11 ];
12}