summaryrefslogtreecommitdiff
path: root/utils/themeeditor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utils/themeeditor/CMakeLists.txt')
-rw-r--r--utils/themeeditor/CMakeLists.txt149
1 files changed, 149 insertions, 0 deletions
diff --git a/utils/themeeditor/CMakeLists.txt b/utils/themeeditor/CMakeLists.txt
new file mode 100644
index 0000000000..e8e137cd4d
--- /dev/null
+++ b/utils/themeeditor/CMakeLists.txt
@@ -0,0 +1,149 @@
1#
2# __________ __ ___.
3# Open \______ \ ____ ____ | | _\_ |__ _______ ___
4# Source | _// _ \_/ ___\| |/ /| __ \ / _ \ \/ /
5# Jukebox | | ( <_> ) \___| < | \_\ ( <_> > < <
6# Firmware |____|_ /\____/ \___ >__|_ \|___ /\____/__/\_ \
7# \/ \/ \/ \/ \/
8#
9# All files in this archive are subject to the GNU General Public License.
10# See the file COPYING in the source tree root for full license agreement.
11#
12# This software is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY
13# KIND, either express or implied.
14#
15
16add_executable(RockboxThemeEditor
17 graphics/rbalbumart.cpp
18 graphics/rbalbumart.h
19 graphics/rbfont.cpp
20 graphics/rbfont.h
21 graphics/rbfontcache.cpp
22 graphics/rbfontcache.h
23 graphics/rbimage.cpp
24 graphics/rbimage.h
25 graphics/rbmovable.cpp
26 graphics/rbmovable.h
27 graphics/rbprogressbar.cpp
28 graphics/rbprogressbar.h
29 graphics/rbrenderinfo.cpp
30 graphics/rbrenderinfo.h
31 graphics/rbscene.cpp
32 graphics/rbscene.h
33 graphics/rbscreen.cpp
34 graphics/rbscreen.h
35 graphics/rbtext.cpp
36 graphics/rbtext.h
37 graphics/rbtextcache.cpp
38 graphics/rbtextcache.h
39 graphics/rbtoucharea.cpp
40 graphics/rbtoucharea.h
41 graphics/rbviewport.cpp
42 graphics/rbviewport.h
43 gui/codeeditor.cpp
44 gui/codeeditor.h
45 gui/configdocument.cpp
46 gui/configdocument.h
47 gui/configdocument.ui
48 gui/devicestate.cpp
49 gui/devicestate.h
50 gui/editorwindow.cpp
51 gui/editorwindow.h
52 gui/editorwindow.ui
53 gui/fontdownloader.cpp
54 gui/fontdownloader.h
55 gui/fontdownloader.ui
56 gui/newprojectdialog.cpp
57 gui/newprojectdialog.h
58 gui/newprojectdialog.ui
59 gui/preferencesdialog.cpp
60 gui/preferencesdialog.h
61 gui/preferencesdialog.ui
62 gui/projectexporter.cpp
63 gui/projectexporter.h
64 gui/projectexporter.ui
65 gui/rbconsole.cpp
66 gui/rbconsole.h
67 gui/rbconsole.ui
68 gui/skindocument.cpp
69 gui/skindocument.h
70 gui/skinhighlighter.cpp
71 gui/skinhighlighter.h
72 gui/skintimer.cpp
73 gui/skintimer.h
74 gui/skintimer.ui
75 gui/skinviewer.cpp
76 gui/skinviewer.h
77 gui/skinviewer.ui
78 gui/syntaxcompleter.cpp
79 gui/syntaxcompleter.h
80 gui/tabcontent.h
81 gui/targetdownloader.cpp
82 gui/targetdownloader.h
83 gui/targetdownloader.ui
84 main.cpp
85 models/parsetreemodel.cpp
86 models/parsetreemodel.h
87 models/parsetreenode.cpp
88 models/parsetreenode.h
89 models/projectmodel.cpp
90 models/projectmodel.h
91 models/targetdata.cpp
92 models/targetdata.h
93 qtfindreplacedialog/finddialog.cpp
94 qtfindreplacedialog/finddialog.h
95 qtfindreplacedialog/findform.cpp
96 qtfindreplacedialog/findform.h
97 qtfindreplacedialog/findreplace_global.h
98 qtfindreplacedialog/findreplacedialog.cpp
99 qtfindreplacedialog/findreplacedialog.h
100 qtfindreplacedialog/findreplacedialog.ui
101 qtfindreplacedialog/findreplaceform.cpp
102 qtfindreplacedialog/findreplaceform.h
103 qtfindreplacedialog/findreplaceform.ui
104 qtfindreplacedialog/varianteditor.cpp
105 qtfindreplacedialog/varianteditor.h
106 quazip/crypt.h
107 quazip/ioapi.c
108 quazip/ioapi.h
109 quazip/quazip.cpp
110 quazip/quazip.h
111 quazip/quazipfile.cpp
112 quazip/quazipfile.h
113 quazip/quazipfileinfo.h
114 quazip/quazipnewinfo.cpp
115 quazip/quazipnewinfo.h
116 quazip/unzip.c
117 quazip/unzip.h
118 quazip/zip.c
119 quazip/zip.h
120 zlib/zconf.h
121 zlib/zlib.h
122 resources.qrc
123 themeeditor.rc
124 )
125set_target_properties(RockboxThemeEditor PROPERTIES AUTOMOC ON)
126set_target_properties(RockboxThemeEditor PROPERTIES AUTORCC ON)
127set_target_properties(RockboxThemeEditor PROPERTIES AUTOUIC ON)
128
129target_link_libraries(RockboxThemeEditor
130 Qt${QT_MAJOR_VERSION}::Network Qt${QT_MAJOR_VERSION}::Widgets Qt${QT_MAJOR_VERSION}::Core
131 skin_parser z)
132target_include_directories(RockboxThemeEditor PRIVATE models graphics gui qtfindreplacedialog quazip)
133target_compile_definitions(RockboxThemeEditor PRIVATE FINDREPLACE_NOLIB)
134
135if(APPLE)
136 # MacOS Application Bundle specifics.
137 target_sources(RockboxThemeEditor PRIVATE
138 ${CMAKE_CURRENT_LIST_DIR}/resources/windowicon.icns)
139 set_target_properties(RockboxThemeEditor
140 PROPERTIES MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_LIST_DIR}/Info.plist)
141 set_source_files_properties(${CMAKE_CURRENT_LIST_DIR}/resources/windowicon.icns
142 PROPERTIES MACOSX_PACKAGE_LOCATION Resources)
143endif()
144
145deploy_qt(RockboxThemeEditor
146 ${QT_BINDIR}
147 ${CMAKE_CURRENT_LIST_DIR}/resources/rbthemeeditor.svg
148 ${CMAKE_CURRENT_LIST_DIR}/RockboxThemeEditor.desktop
149 ${CMAKE_CURRENT_LIST_DIR}/dmgbuild.cfg)