summaryrefslogtreecommitdiff
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index d874f083b5..fc122426a2 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -48,13 +48,15 @@ enable_testing()
48# Qt 48# Qt
49find_package(QT NAMES Qt6 Qt5 REQUIRED) 49find_package(QT NAMES Qt6 Qt5 REQUIRED)
50if(QT_VERSION_MAJOR EQUAL 5) 50if(QT_VERSION_MAJOR EQUAL 5)
51 find_package(Qt5 COMPONENTS Core Widgets Svg Multimedia Network Test LinguistTools REQUIRED) 51 find_package(Qt5 REQUIRED COMPONENTS
52 Core Widgets Svg Multimedia Network Test LinguistTools)
52else() 53else()
53 find_package(Qt6 REQUIRED COMPONENTS Core Core5Compat Widgets Svg Multimedia Network LinguistTools 54 find_package(Qt6 REQUIRED COMPONENTS
55 Core Core5Compat Widgets Svg Multimedia Network LinguistTools SvgWidgets
54 OPTIONAL_COMPONENTS Test) 56 OPTIONAL_COMPONENTS Test)
55endif() 57endif()
56get_target_property(_qmake_executable Qt${QT_VERSION_MAJOR}::qmake IMPORTED_LOCATION) 58get_target_property(_moc_executable Qt${QT_VERSION_MAJOR}::moc IMPORTED_LOCATION)
57get_filename_component(QT_BINDIR "${_qmake_executable}" DIRECTORY) 59get_filename_component(QT_BINDIR "${_moc_executable}" DIRECTORY)
58message("-- Found Qt${QT_VERSION_MAJOR}: ${Qt${QT_VERSION_MAJOR}_DIR}") 60message("-- Found Qt${QT_VERSION_MAJOR}: ${Qt${QT_VERSION_MAJOR}_DIR}")
59 61
60# If we're on Linux, try to find the used libs in the system. 62# If we're on Linux, try to find the used libs in the system.