summaryrefslogtreecommitdiff
path: root/apps/plugins/sdl/progs/duke3d/Game/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'apps/plugins/sdl/progs/duke3d/Game/src/Makefile.am')
-rw-r--r--apps/plugins/sdl/progs/duke3d/Game/src/Makefile.am14
1 files changed, 0 insertions, 14 deletions
diff --git a/apps/plugins/sdl/progs/duke3d/Game/src/Makefile.am b/apps/plugins/sdl/progs/duke3d/Game/src/Makefile.am
deleted file mode 100644
index 78af7efb8d..0000000000
--- a/apps/plugins/sdl/progs/duke3d/Game/src/Makefile.am
+++ /dev/null
@@ -1,14 +0,0 @@
1SUBDIRS = audiolib midi
2
3noinst_LIBRARIES = libGame.a
4
5libGame_a_SOURCES = \
6 actors.c animlib.c config.c console.c control.c cvar_defs.c cvars.c dummy_audiolib.c game.c \
7 gamedef.c global.c keyboard.c menues.c player.c rts.c scriplib.c sector.c sounds.c
8libGame_a_LIBADD = premap.o
9libGame_a_CFLAGS = -I$(top_srcdir)/Engine/src
10
11# Starting a new game will lead to a crash if premap.o was built with -O1/-O2/-O3,
12# that's why we're compiling it seperately with -O0
13premap.o: premap.c
14 $(AM_V_CC)$(CC) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -I$(top_srcdir)/Engine/src -O0 -c $^ -o $@