diff options
Diffstat (limited to 'apps/plugins/puzzles/src/unfinished/CMakeLists.txt')
-rw-r--r-- | apps/plugins/puzzles/src/unfinished/CMakeLists.txt | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/apps/plugins/puzzles/src/unfinished/CMakeLists.txt b/apps/plugins/puzzles/src/unfinished/CMakeLists.txt new file mode 100644 index 0000000000..0c1e331f9b --- /dev/null +++ b/apps/plugins/puzzles/src/unfinished/CMakeLists.txt | |||
@@ -0,0 +1,31 @@ | |||
1 | puzzle(group | ||
2 | DISPLAYNAME "Group" | ||
3 | DESCRIPTION "Group theory puzzle" | ||
4 | OBJECTIVE "Complete the unfinished Cayley table of a group.") | ||
5 | solver(group ${CMAKE_SOURCE_DIR}/latin.c) | ||
6 | |||
7 | puzzle(separate | ||
8 | DISPLAYNAME "Separate" | ||
9 | DESCRIPTION "Rectangle-dividing puzzle" | ||
10 | OBJECTIVE "Partition the grid into regions containing one of each letter.") | ||
11 | |||
12 | puzzle(slide | ||
13 | DISPLAYNAME "Slide" | ||
14 | DESCRIPTION "Sliding block puzzle" | ||
15 | OBJECTIVE "Slide the blocks to let the key block out.") | ||
16 | solver(slide) | ||
17 | |||
18 | puzzle(sokoban | ||
19 | DISPLAYNAME "Sokoban" | ||
20 | DESCRIPTION "Barrel-pushing puzzle" | ||
21 | OBJECTIVE "Push all the barrels into the target squares.") | ||
22 | |||
23 | # These unfinished programs don't even have the structure of a puzzle | ||
24 | # game yet; they're just command-line programs containing test | ||
25 | # implementations of some of the needed functionality. | ||
26 | |||
27 | cliprogram(numgame numgame.c) | ||
28 | |||
29 | cliprogram(path path.c COMPILE_DEFINITIONS TEST_GEN) | ||
30 | |||
31 | export_variables_to_parent_scope() | ||