summaryrefslogtreecommitdiff
path: root/utils/themeeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Riebeling <Dominik.Riebeling@gmail.com>2022-03-11 20:37:06 +0100
committerDominik Riebeling <Dominik.Riebeling@gmail.com>2022-03-12 20:40:08 +0100
commit0de2d3a0b6941c566713309078eeed9a8972bae4 (patch)
tree934e602b2991068659430b7e49d99509216805e5 /utils/themeeditor/CMakeLists.txt
parent7319356dfdeaf16282ef39d05a3213c1d7dc324d (diff)
downloadrockbox-0de2d3a0b6941c566713309078eeed9a8972bae4.tar.gz
rockbox-0de2d3a0b6941c566713309078eeed9a8972bae4.zip
utils: rework cmake deploy function.
Use named arguments for function and allow passing additional executable targets to be copied to the deploy tree. Update current uses and add ipodpatcher and sansapatcher to Rockbox Utility deployment. This is in preparation for moving ipodpatcher / sansapatcher functionality out of Rockbox Utility so we eventually can avoid elevation / sudo of the whole installer. Currently this only results in Rockbox Utility releases shipping ipodpatcher / sansapatcher executables. Change-Id: Ibb6601b7e437648135059c580e2ce2532574835a
Diffstat (limited to 'utils/themeeditor/CMakeLists.txt')
-rw-r--r--utils/themeeditor/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/utils/themeeditor/CMakeLists.txt b/utils/themeeditor/CMakeLists.txt
index d0957a96da..b29265898a 100644
--- a/utils/themeeditor/CMakeLists.txt
+++ b/utils/themeeditor/CMakeLists.txt
@@ -142,8 +142,9 @@ if(APPLE)
142 PROPERTIES MACOSX_PACKAGE_LOCATION Resources) 142 PROPERTIES MACOSX_PACKAGE_LOCATION Resources)
143endif() 143endif()
144 144
145deploy_qt(RockboxThemeEditor 145deploy_qt(TARGET RockboxThemeEditor
146 ${QT_BINDIR} 146 QTBINDIR ${QT_BINDIR}
147 ${CMAKE_CURRENT_LIST_DIR}/resources/rbthemeeditor.svg 147 ICONFILE ${CMAKE_CURRENT_LIST_DIR}/resources/rbthemeeditor.svg
148 ${CMAKE_CURRENT_LIST_DIR}/RockboxThemeEditor.desktop 148 DESKTOPFILE ${CMAKE_CURRENT_LIST_DIR}/RockboxThemeEditor.desktop
149 ${CMAKE_CURRENT_LIST_DIR}/dmgbuild.cfg) 149 DMGBUILDCFG ${CMAKE_CURRENT_LIST_DIR}/dmgbuild.cfg)
150