summaryrefslogtreecommitdiff
path: root/apps/plugins/puzzles/src/unfinished/CMakeLists.txt
diff options
context:
space:
mode:
authorFranklin Wei <franklin@rockbox.org>2024-08-18 21:14:07 -0400
committerFranklin Wei <franklin@rockbox.org>2024-08-25 19:30:01 -0400
commiteca00638aeab59cf03287b9f298c86a6de1b5a9a (patch)
tree32f14d7c1a05f86b2ba7e91be647233570203599 /apps/plugins/puzzles/src/unfinished/CMakeLists.txt
parent3dd69ce23e3089ac78c512f02e59406d05302fa4 (diff)
downloadrockbox-eca00638aeab59cf03287b9f298c86a6de1b5a9a.tar.gz
rockbox-eca00638aeab59cf03287b9f298c86a6de1b5a9a.zip
puzzles: add Slide and Sokoban.
This enables two of the "unfinished" puzzles. Slide requires a new "sticky mouse mode" to enable dragging. The help system is disabled for these puzzles, since they lack manual chapters. Group is currently unplayable due to lack of request_keys() support, which will need to be added upstream. Separate fails to draw anything. Change-Id: I7bcff3679ac5b10b0f39c5eaa19a36b4b1fe8d53
Diffstat (limited to 'apps/plugins/puzzles/src/unfinished/CMakeLists.txt')
-rw-r--r--apps/plugins/puzzles/src/unfinished/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/apps/plugins/puzzles/src/unfinished/CMakeLists.txt b/apps/plugins/puzzles/src/unfinished/CMakeLists.txt
new file mode 100644
index 0000000000..0c1e331f9b
--- /dev/null
+++ b/apps/plugins/puzzles/src/unfinished/CMakeLists.txt
@@ -0,0 +1,31 @@
1puzzle(group
2 DISPLAYNAME "Group"
3 DESCRIPTION "Group theory puzzle"
4 OBJECTIVE "Complete the unfinished Cayley table of a group.")
5solver(group ${CMAKE_SOURCE_DIR}/latin.c)
6
7puzzle(separate
8 DISPLAYNAME "Separate"
9 DESCRIPTION "Rectangle-dividing puzzle"
10 OBJECTIVE "Partition the grid into regions containing one of each letter.")
11
12puzzle(slide
13 DISPLAYNAME "Slide"
14 DESCRIPTION "Sliding block puzzle"
15 OBJECTIVE "Slide the blocks to let the key block out.")
16solver(slide)
17
18puzzle(sokoban
19 DISPLAYNAME "Sokoban"
20 DESCRIPTION "Barrel-pushing puzzle"
21 OBJECTIVE "Push all the barrels into the target squares.")
22
23# These unfinished programs don't even have the structure of a puzzle
24# game yet; they're just command-line programs containing test
25# implementations of some of the needed functionality.
26
27cliprogram(numgame numgame.c)
28
29cliprogram(path path.c COMPILE_DEFINITIONS TEST_GEN)
30
31export_variables_to_parent_scope()