aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am72
1 files changed, 72 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..a972643
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,72 @@
1#
2# automake Makefile.am for the PrBoom source directory
3#
4#
5# Process this file with automake to produce Makefile.in
6#
7#
8
9SUBDIRS = SDL POSIX MAC
10
11gamesdir=$(prefix)/games
12games_PROGRAMS = prboom prboom-game-server
13
14CFLAGS = @CFLAGS@ @SDL_CFLAGS@
15
16prboom_game_server_SOURCES = d_server.c protocol.h
17prboom_game_server_LDADD = POSIX/libposixdoom.a SDL/i_network.o @NET_LIBS@ @SDL_LIBS@
18
19COMMON_SRC = \
20 am_map.c g_game.c p_maputl.h r_plane.h \
21 am_map.h g_game.h p_mobj.c r_demo.c r_segs.c \
22 hu_lib.c lprintf.c p_mobj.h r_demo.h r_segs.h \
23 hu_lib.h lprintf.h p_plats.c r_sky.c \
24 d_deh.c hu_stuff.c m_argv.c p_pspr.c r_sky.h \
25 d_deh.h hu_stuff.h m_argv.h p_pspr.h r_state.h \
26 d_englsh.h i_joy.h m_bbox.c p_saveg.c r_things.c \
27 d_event.h m_bbox.h p_saveg.h r_things.h \
28 d_items.c i_network.h m_cheat.c p_setup.c s_sound.c \
29 d_items.h i_sound.h m_cheat.h p_setup.h s_sound.h \
30 d_main.c i_system.h m_fixed.h p_sight.c sounds.c \
31 d_main.h i_video.h m_menu.c p_spec.c sounds.h \
32 info.c m_menu.h p_spec.h st_lib.c \
33 d_net.h info.h m_misc.c p_switch.c st_lib.h \
34 d_player.h m_misc.h p_telept.c st_stuff.c \
35 m_random.c p_tick.c st_stuff.h i_main.h \
36 d_think.h m_random.h p_tick.h tables.c \
37 d_ticcmd.h m_swap.h p_user.c tables.h \
38 doomdata.h p_ceilng.c p_user.h v_video.c \
39 doomdef.c p_doors.c protocol.h v_video.h \
40 doomdef.h p_enemy.c r_bsp.c version.c \
41 doomstat.c p_enemy.h r_bsp.h version.h \
42 doomstat.h p_floor.c r_data.c w_wad.c \
43 doomtype.h p_genlin.c r_data.h w_wad.h \
44 dstrings.c p_inter.c r_defs.h wi_stuff.c \
45 dstrings.h p_inter.h r_draw.c wi_stuff.h \
46 f_finale.c p_lights.c r_draw.h z_bmalloc.c \
47 f_finale.h p_map.c r_main.c z_bmalloc.h \
48 f_wipe.c p_map.h r_main.h z_zone.c \
49 f_wipe.h p_maputl.c r_plane.c z_zone.h \
50 md5.c md5.h p_checksum.h p_checksum.c \
51 r_patch.c r_patch.h r_fps.c r_fps.h \
52 r_filter.c r_filter.h
53
54NET_CLIENT_SRC = d_client.c
55
56if BUILD_GL
57USE_GL_SRC = gl_intern.h gl_main.c gl_struct.h gl_texture.c
58else
59USE_GL_SRC =
60endif
61
62if WAD_MMAP
63WAD_SRC = w_mmap.c
64else
65WAD_SRC = w_memcache.c
66endif
67
68prboom_SOURCES = mmus2mid.c mmus2mid.h $(COMMON_SRC) $(NET_CLIENT_SRC) $(USE_GL_SRC) $(WAD_SRC)
69prboom_LDADD = SDL/libsdldoom.a @MIXER_LIBS@ @NET_LIBS@ @SDL_LIBS@ @GL_LIBS@ @MATH_LIB@
70
71EXTRA_DIST = \
72 r_drawcolumn.inl r_drawflush.inl r_drawspan.inl r_drawcolpipeline.inl