summaryrefslogtreecommitdiff
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Riebeling <Dominik.Riebeling@gmail.com>2022-04-14 22:23:35 +0200
committerDominik Riebeling <Dominik.Riebeling@gmail.com>2022-04-14 22:23:35 +0200
commit6ef094c1a91d5ae50c56c8192f617f55eea25751 (patch)
tree2791b9673d8b67e84e50fd2494bb118d87d0b151 /utils/CMakeLists.txt
parent8a6ceff3762784d99f57e2f7f20149f97b6d82c7 (diff)
downloadrockbox-6ef094c1a91d5ae50c56c8192f617f55eea25751.tar.gz
rockbox-6ef094c1a91d5ae50c56c8192f617f55eea25751.zip
rbutil: Make QtMultimedia an optional component.
We only use it for playing the TTS sample so it's not too important. Since this is a separate Qt module it might not be installed, so make it optional. Change-Id: I2c91dd5d587c8a984525b2297bbe7d597b816b4f
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index fc122426a2..55e5b7991f 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -52,8 +52,8 @@ if(QT_VERSION_MAJOR EQUAL 5)
52 Core Widgets Svg Multimedia Network Test LinguistTools) 52 Core Widgets Svg Multimedia Network Test LinguistTools)
53else() 53else()
54 find_package(Qt6 REQUIRED COMPONENTS 54 find_package(Qt6 REQUIRED COMPONENTS
55 Core Core5Compat Widgets Svg Multimedia Network LinguistTools SvgWidgets 55 Core Core5Compat Widgets Svg Network LinguistTools SvgWidgets
56 OPTIONAL_COMPONENTS Test) 56 OPTIONAL_COMPONENTS Multimedia Test)
57endif() 57endif()
58get_target_property(_moc_executable Qt${QT_VERSION_MAJOR}::moc IMPORTED_LOCATION) 58get_target_property(_moc_executable Qt${QT_VERSION_MAJOR}::moc IMPORTED_LOCATION)
59get_filename_component(QT_BINDIR "${_moc_executable}" DIRECTORY) 59get_filename_component(QT_BINDIR "${_moc_executable}" DIRECTORY)