summaryrefslogtreecommitdiff
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Riebeling <Dominik.Riebeling@gmail.com>2022-03-11 20:34:50 +0100
committerDominik Riebeling <Dominik.Riebeling@gmail.com>2022-03-12 20:40:08 +0100
commit748b00a7fcd0e9d820fd04fdf13422eaad4c2dd4 (patch)
tree521962473cf2b3b0f563a42bced3b5a6eef2aac0 /utils/CMakeLists.txt
parent08afedf1f51194eea3c121245cfdfba7bb936323 (diff)
downloadrockbox-748b00a7fcd0e9d820fd04fdf13422eaad4c2dd4.tar.gz
rockbox-748b00a7fcd0e9d820fd04fdf13422eaad4c2dd4.zip
ipodpatcher: Split executable only parts out.
Allow building both as library and executable at the same time. Change-Id: Idc40354fdedaeace727043936352fc17232bf16e
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index 9797d020d3..d874f083b5 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -82,6 +82,17 @@ if(APPLE)
82endif() 82endif()
83 83
84 84
85add_executable(ipodpatcher-bin
86 ipodpatcher/main.c
87 ipodpatcher/ipodpatcher-aupd.c
88 )
89target_link_libraries(ipodpatcher-bin ipodpatcher)
90target_compile_definitions(ipodpatcher-bin PRIVATE VERSION="none")
91set_target_properties(ipodpatcher-bin PROPERTIES OUTPUT_NAME ipodpatcher)
92if(APPLE)
93 target_link_libraries(ipodpatcher-bin ${FRAMEWORK_IOKIT} ${FRAMEWORK_COREFOUNDATION})
94endif()
95
85add_library(ipodpatcher 96add_library(ipodpatcher
86 ipodpatcher/arc4.h 97 ipodpatcher/arc4.h
87 ipodpatcher/arc4.c 98 ipodpatcher/arc4.c